Ambur Cloud Reporting
Incident Report for Ambur
Resolved
The resolution has been fully confirmed and AmburCloud performance is back to normal.
Posted 24 days ago. Aug 02, 2019 - 12:35 EDT
Investigating
Some Ambur users are reporting missing information in their AmburCloud Reporting. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 27 days ago. Jul 29, 2019 - 20:35 EDT
This incident affected: AmburCloud.