Ambur Cloud Experiencing Login Issues
Incident Report for Ambur
Resolved
The resolution has been fully confirmed and AmburCloud performance is back to normal.
Posted 2 months ago. Oct 08, 2017 - 11:06 EDT
Investigating
Ambur Cloud is currently experiencing issues causing users to be unable to login to Ambur Cloud. We are currently investigating the issue and will update as we identify the issue.
Posted 2 months ago. Oct 07, 2017 - 22:15 EDT