Ambur - AmburCloud
Incident Report for Ambur
Resolved
The resolution has been fully confirmed and AmburCloud performance is back to normal.
Posted 29 days ago. Aug 24, 2017 - 13:39 EDT
Investigating
Some Ambur users are reporting an inability to access their AmburCloud. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 29 days ago. Aug 24, 2017 - 13:28 EDT