Issues completing credit card transactions
Incident Report for Ambur
Resolved
This incident has been resolved.
Posted 6 months ago. May 28, 2017 - 17:11 EDT
Identified
We've received reports that some merchants are experiencing issues processing credit cards.

We’ve confirmed that an issue at our credit card gateway has caused unexpected downtime. They are aware of the issue and are working to resolve as quickly as possible.
Posted 6 months ago. May 28, 2017 - 14:04 EDT