Ambur Phone Service Issue
Incident Report for Ambur
Resolved
All Phone lines have been restored.
Posted Feb 18, 2020 - 00:34 EST
Update
We are currently experiencing issues with our phone system preventing merchants from contacting Ambur Customer Care. This is being investigated. Please subscribe for updates.

Please use the following inbound toll free numbers:
Support - +1 844-368-2507
Posted Feb 17, 2020 - 13:20 EST
Investigating
We are currently experiencing issues with our phone system preventing merchants from contacting Ambur Customer Care. This is being investigated. Please subscribe for updates.
Posted Feb 17, 2020 - 13:11 EST
This incident affected: Support (Phone).