Ambur Cloud Availability
Incident Report for Ambur
Resolved
This incident has been resolved.
Posted 8 days ago. Mar 20, 2017 - 16:10 EDT
Identified
There are currently reports from multiple merchants affecting the connection to AmburCloud.com. We have currently identified the issue and are working toward a resolution as soon as possible. Please subscribe to updates for the most up to date information.
Posted 8 days ago. Mar 20, 2017 - 15:24 EDT